Guide on how to get SLI working in bf5

Comments

  • REPERCUSSIONS
    222 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, Battlefield V Member
    it does work but all of a sudden lines.... And yes my power supply is to to the task.
  • REPERCUSSIONS
    222 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, Battlefield V Member
    thats if i overclock the gpus or not.... just random
  • Dragam
    871 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, Battlefield V Member
    edited December 2018
    forcing sli seems to cause video glitches like crazy lines.... Any suggestions?

    Did you do exactly what my guide says ?
  • d0lob
    31 postsMember, Battlefield 3, Battlefield, Battlefield 1, Battlefield V Member
    edited December 2018
    Thanks for posting this man.

    Previously I used the bf1 compatibility bits without all the other settings you mentioned and the some of the textures sometimes flickered like crazy (especially with ground deformation) nearly inducing epileptic seizures ;/
    With your settings I still get some flickering textures from time to time. But it is a lot less and very playable

    My old 970's in SLI still give me 65-90fps on ultra settings @ 1440p and about 85-130 fps on low settings with high TXAA (low txaa looks really bad and blurry). Me happy now :D


    After a few days of testing with op's settings I sadly have to report the same flickering textures issue. As soon as a vehicle leaves a trail on the ground the textures on the trail start flickering for the entire duration of the map. Simply unplayable for me
    Post edited by d0lob on
  • IdiotBox
    41 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, Battlefield V Member
    edited December 2018
    Kranden wrote: »
    Is there a workaround to getting SLI to function properly without FFR? Really not worth it to me to use FFR

    No, there is no "workaround" to get SLI to "function properly" without FFR. Even in "single card" configuration, BF5 does not "function properly" without FFR in DX11.
    jasonvp wrote: »
    As a follow-up to my post, some other suggestions from various folks:
    - Force anistropic filtering to "x16" in the NVCP - This might help with any of the visual glitches that pop up with SLI enabled.
    - Force frame rendering to "4" in the NVCP - This seems to help with the massive frame dumps at the potential cost of some input latency (I don't notice any).

    It straight up says (as seen in the screenshot in this thread) "this setting does not apply to SLI". Forcing to 1 frame in NVCP instead of "application controlled" made literally no difference in performance for me. But setting FFR to 2 frames in game via console (instead of default 3) with NVCP set to force 1? RIP FPS.

  • jasonvp
    189 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha, Battlefield V Member
    IdiotBox wrote: »
    It straight up says (as seen in the screenshot in this thread) "this setting does not apply to SLI".

    And I "straight up said" that I hadn't noticed that and thanked him for pointing it out. You "straight up" read the whole thread before responding, right?
  • Dragam
    871 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, Battlefield V Member
    Bump to remind everyone how to do this simple fix :)
  • weaser31
    1 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, BF1IncursionsAlpha, Battlefield V Member
    I am getting weird rainbow lines, anyone find a fix for that
  • Dragam
    871 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, Battlefield V Member
    weaser31 wrote: »
    I am getting weird rainbow lines, anyone find a fix for that

    Screenshot ?

    Usually rainbow colors with sli indicates something is wrong with the sli bridge - either it isn't seated properly, or the sli fingers needs a cleaning, or the bridge is defect.
  • Dragam
    871 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, Battlefield V Member
    d0lob wrote: »
    Thanks for posting this man.

    Previously I used the bf1 compatibility bits without all the other settings you mentioned and the some of the textures sometimes flickered like crazy (especially with ground deformation) nearly inducing epileptic seizures ;/
    With your settings I still get some flickering textures from time to time. But it is a lot less and very playable

    My old 970's in SLI still give me 65-90fps on ultra settings @ 1440p and about 85-130 fps on low settings with high TXAA (low txaa looks really bad and blurry). Me happy now :D


    After a few days of testing with op's settings I sadly have to report the same flickering textures issue. As soon as a vehicle leaves a trail on the ground the textures on the trail start flickering for the entire duration of the map. Simply unplayable for me

    The solution is to force anisotropic filtering x16 through nvidia control panel - just do it in the global profile.

    When you don't have ani at 16x in NVCP it looks like this and flicker :

    2YwOkMl.jpg

    When you do have it enabled, it will instead be like this :

    MJSQ9wi.jpg
  • jasonvp
    189 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha, Battlefield V Member
  • tedrampart
    109 postsMember, Battlefield 4, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha, Battlefield V Member
    I get the rainbow lines if I do any sort of resolution scale and also have post processing med or higher.. set it to low and no rainbow lines and can scale whatever %.
  • Dragam
    871 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, Battlefield V Member
    tedrampart wrote: »
    I get the rainbow lines if I do any sort of resolution scale and also have post processing med or higher.. set it to low and no rainbow lines and can scale whatever %.

    Keep post processing at high - just alt-tab out and into the game, and it should look normal again.
  • Dragam
    871 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, Battlefield V Member
    jasonvp wrote: »

    Very nice, good work :)
  • IronMaiden1973
    6 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, CTE, Battlefield V Member
    edited December 2018
    Cheers for this post mate. I posted a post the other day about my troubles here :
    https://forums.battlefield.com/en-us/discussion/171970/sli-isnt-working-with-sli-bits-anymore#latest

    But after reading your post I found that the key was to set Future Frame Rendering to ON in game.. Now it works.
    Such a small setting to stop it from working.. All is good now. Back up to 100-120 in 4k.. Nice.
  • jasonvp
    189 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha, Battlefield V Member
    edited December 2018
    Dragam wrote: »
    Keep post processing at high - just alt-tab out and into the game, and it should look normal again.

    Remember that Post Processing is a mostly-useless visual addition that does little more than raise the load on the GPU and drop the overall FPS. Personally, I always disable it and err toward performance.
  • Dragam
    871 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, Battlefield V Member
    jasonvp wrote: »
    Dragam wrote: »
    Keep post processing at high - just alt-tab out and into the game, and it should look normal again.

    Remember that Post Processing is a mostly-useless visual addition that does little more than raise the load on the GPU and drop the overall FPS. Personally, I always disable it and err toward performance.

    I usually like it, but each to their own :)
  • GumTooth
    11 postsMember, Battlefield, Battlefield 1, Battlefield V Member
    I tried this according to a YouTube video, however I would get a BSOD after doing this (System Service Exception), SLI would work great...except this error and the fact that sometimes when I would load the game I would get artifacting happening...any thoughts?
  • Dragam
    871 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, Battlefield V Member
    GumTooth wrote: »
    I tried this according to a YouTube video, however I would get a BSOD after doing this (System Service Exception), SLI would work great...except this error and the fact that sometimes when I would load the game I would get artifacting happening...any thoughts?

    I have no idea what this youtube video says - if you want my help, follow the guide i made.
  • GumTooth
    11 postsMember, Battlefield, Battlefield 1, Battlefield V Member
    Ok will do boss, I'm kinda computer dumb and thought it had me basically do the same thing. I'll follow your guide and get back to you if thats cool.
Sign In or Register to comment.