Low FPS

Bumstag1
60 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha, Battlefield V Member
i7 7700k overclocked to 4.8 Ghz (hyperthreading enabled, without it I get even lower FPS)
16 GB 2666 mhz RAM with XMP enabled
EVGA GTX 1080 TI SC2 Gaming overclocked
Gigabyte Aorus Z270X Gaming 5 motherboard
2560x1440p 144hz G-sync monitor

So I'm getting drops sometimes below 60, average FPS is around 70-80. This is on ultra settings. I consider this very low with these kind of specs. With DX11 it is even lower, if I enable Future Frame Rendering then I get the same FPS as if I was running it with DX12, so I'm running the game with DX12 and FFR turned off so that I do not get any imput lag.
The BIOS is up to date, as well as the OS (Windows 10 pro 64-bit version 1809), and the nvidia drivers. From this point on I have basically run out of options, nobody knows anything, I've been asking for help from everyone. Is there anything I can do?

Comments

  • BlindChance
    484 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, Battlefield V Member
    edited December 2018
    Not without posting your detailed graphical settings. Also one of the reasons why I don't see a point from moving on from 1080p monitor.
  • Bumstag1
    60 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha, Battlefield V Member
    What detailed graphical settings? Everything is on ultra and it's on a 1440p display, resolution scale is 100%. What more do you need?
  • Huntinwabits
    121 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, Battlefield V Member
    turn off Hbao and ssoa thing. somin wrong with that . makes mine run better
  • Reeeebz
    12 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, Battlefield V Member
    also what can help is choosing a diffirent update for your Graphics card some times the lastest updates tends to **** things up, try a later version or roll the driver back it seems to help me an im not getting no stutter issues im not using the lastest graphic drivers
  • Bumstag1
    60 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha, Battlefield V Member
    Reeeebz wrote: »
    also what can help is choosing a diffirent update for your Graphics card some times the lastest updates tends to **** things up, try a later version or roll the driver back it seems to help me an im not getting no stutter issues im not using the lastest graphic drivers

    Which driver do you have?
  • OskooI_007
    667 postsMember, Battlefield, Battlefield 1, Battlefield V Member
    Your ram in dual channel mode?
  • Bumstag1
    60 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha, Battlefield V Member
    OskooI_007 wrote: »
    Your ram in dual channel mode?

    No, it is not. Could that be an issue?
  • OskooI_007
    667 postsMember, Battlefield, Battlefield 1, Battlefield V Member
    Dual channel mode should boost your minimum framerate by 20fps.
  • GOA-Johnny-BK-
    256 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, Battlefield V Member
    Yes for sure you want daul channel. Just grab yourself another stick and you'll be good to go.
  • Bumstag1
    60 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha, Battlefield V Member
    Thank you for your help. Dual channel mode fixed all my issues, I have 100+ FPS on Rotterdam breakthrough. Thankfully I have 2x8 gigs of RAM so just moving one of them to the other slot helped me. Had to reset BIOS to its default mode but after messing around in the settings I got it all back to its former state.
  • OskooI_007
    667 postsMember, Battlefield, Battlefield 1, Battlefield V Member
    edited December 2018
    Awesome! Glad dual channel mode fixed it.
Sign In or Register to comment.