Battlefield 5 low brightness when using Freesync

ArjenM44
1 postsMember, Battlefield 3, Battlefield, Battlefield 1, Battlefield V Member
Hello,

I recently got a new videcard (AMD RX5700XT). Everything runs just fine, except Battlefield 5.
Everytime I load into BF and I'm in fullscreen, my brightness lowers, I can still see everything but everything is just very dark.
When I don't use Freesync the brightness doesn't lower and everything is normal.

With my previous GPU (gtx 1070) I had no problems with Battlefield 5.

Specs and additional info:

Specs: 

GPU: Gigabyte AMD  rx 5700 xt GAMING OC
CPU: Intel Core I7-8700K 
PSU: Corsair cx550
MB: MSI Z390 A-PRO
RAM: 2x8 GB DDR4 @ 2666.

Additional Info:

Connection type: Displayport 1.2
Windows 10 version: latest and fully updated
Monitor: Samsung LC27FG73FQUXEN
AMD Drivers: Latest updates

Thanks for helping me out.


Comments

  • Riflen
    37 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, Battlefield V Member
    If the GPU driver settings have FreeSync Engine set to Ultimate, try setting it to Standard instead.
  • Carbonic
    1664 postsMember, Moderator, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha, Battlefield V Moderator
    Just a quick tip, never write "latest and fully updated" and "Latest updates" - always write the specific version you are using when asking for help/support, otherwise they will always assume you don't know how to check the version and that you don't have the latest :)
  • ArjenM44
    1 postsMember, Battlefield 3, Battlefield, Battlefield 1, Battlefield V Member
    I already tried using the standard engine, still the same result. When I'm not using Freesync the brightness doesn't lower, but since im so used to playing with freesync it feels stuttery when I don't use it. 

    Thanks for the tip, I used the words "latest updates"  because new drivers are coming out every week. Also I'm using windows 10 home. build 1909. 
  • OskooI_007
    1079 postsMember, Battlefield 4, Battlefield, Battlefield 1, Battlefield V Member
    edited December 2019
    There appears to be a Faster and Fastest Response Time setting in the OSD (On-Screen Display) menu for your monitor. These two settings enable backlight strobing which will cause the screen's brightness to dim.
    * Slight flickers may occur and the FreeSync cannot be used if the fastest mode or faster mode is selected.

    https://displaysolutions.samsung.com/monitor/detail/1113/C27FG73
    Furthermore, once you set the Response Time setting in the OSD (On-Screen Display) menu to ‘Faster’ or ‘Fastest’, the monitor enables the 1ms MPRT technology which via backlight strobing further reduces motion blur and ghosting in fast-paced games.

    Keep in mind that, while the motion blur reduction technology is enabled, it reduces the monitor’s maximum brightness to around ~230-nits which is still quite bright.

    https://www.displayninja.com/samsung-c24fg73-review/

    You can also try turning Local Dimming off in the monitor's menu. Also turn off EcoSaving and EyeSaver Mode. Check the Black Equalizer setting too.

    There's also 3 levels of Gamma to choose from in the monitor's menu.

    Perhaps turning FreeSync on resets the brightness slider in the monitor's menu? You should be able to adjust the Brightness slider with FreeSync on.

    The FreeSync range of your monitor is 70-144fps in Ultimate Mode, so you'll definitely want to keep the frame rate within that range.

    Did you install the drivers for your monitor from Samsung's website?

    https://www.samsung.com/us/support/owners/product/curved-gaming-monitor-cfg73-series


    If all of the above fails, then try disabling HDR in Battlefield V's video settings and restart the game a few times. The HDR setting in Battlefield is a little buggy, so make sure to restart the game more than once.

    I say this because HDR only works in fullscreen mode. So if you're only having brightness problems in fullscreen mode, then it has something to do with HDR.
    Post edited by OskooI_007 on
Sign In or Register to comment.