I can't open BF4 via Origin, I don't want to use battlelog.

DocRye28
1 postsMember, Battlefield 4, Battlefield, Battlefield 1 Member
When I open the BF4 game on Origin, It keeps redirecting me to Battelog. I don't like using battlelog.. Tried clearing Origin cache and repairing the game but it still doesn't fix it. Can anyone help me? Thanks!

Comments

  • DATOLLOLLITO
    2 postsMember, Battlefield 4, Battlefield Member
    I'm having the same issue, started today. On top of it all, now I am getting kicked out by punk
  • DaDrunkMonkey
    2 postsMember, Battlefield 4, Battlefield, Battlefield 1, Battlefield V Member
    yeah this needs reverted, if this is a permanent change i'm just refunding the steam version i just bought
  • killer_ghost312
    3 postsMember, Battlefield 4, Battlefield Member
    are this gonna fixed in sometime or not?
    because I hate to play from Battlelog 
  • J4ksha
    5 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1 Member
    Hey just sharing what one user said on r/battlefied_4
    ThemRaisins: Easiest way to fix this issue is launch from origin while origin in offline mode, when game launched switch back to online! That wroks for now until issue fixed!!
    Best of luck until EA remembers us.
  • killer_ghost312
    3 postsMember, Battlefield 4, Battlefield Member
    well today its back so
  • MyJetpack
    27 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, Battlefield V Member
    Its started doing the Battlelog thing to me today as well.
  • Bustamaru
    1 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1 Member
    MyJetpack said:
    Its started doing the Battlelog thing to me today as well.
    Same thing for me, annoying AF even after years of being released EA still is **** on the game
  • IIPrest0nII
    2488 postsMember, Moderator, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha, Battlefield V Moderator
    Hi all,

    Try this workaround:

    Open Origin client and right-click Battlefield 4 and choose Game Properties. Then go to Advanced Launch Options and choose Battlefield 4 x86 and click Save. After that, go to Advanced Launch Options again and choose back Battlefield 4 x64 and Save.
  • killer_ghost312
    3 postsMember, Battlefield 4, Battlefield Member
    hey ty prest0n for help its fixed
Sign In or Register to comment.