Poor Performance? Here's a collection of tips so far!

«13
-LIPs-Kashinoda
46 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1 Member
edited October 2016
This is not a definitive list of things that will definitely boost your FPS, the solutions may help those experiencing unexpected low performance or stuttering. I will continue to update this.

ShadowPlay or PlaysTV:
  • It seems ShadowPlay has been causing huge FPS drops (reducing frames by like 50) for whatever reason. Make sure you have it disabled until Nvidia releases a driver update. I haven't seen many problems from AMD users but this might also apply to Raptr/PlaysTV, so disable these. To see how to disable ShadowPlay see this video: https://goo.gl/Q52UqW

Drivers - Latest: AMD [16.10.2] 20th October, Nvidia [375.57] 21ST October
High/100% CPU Usage - Potential workaround 1 - (EA are aware of this issue and are working to patch it.)
  • Make a file name 'user.cfg' and place it in your Battlefield 1 folder, add the following lines:
gametime.maxvariablefps 60
RenderDevice.RenderAheadLimit 1
  • We're using 60 to limit the FPS, ideally you want this to match your refresh rate. If you're using a higher frequency display (i.e. 144hz) see if you get stable results at 60, then increase it gradually.
  • The RenderDevice.RenderAheadLimit is actually 0 by default, experiment with values 1,2 and 3.
  • You can also also change these values in nVidia/AMD control panel if you prefer, there's a discussion on this here: https://forums.battlefield.com/en-us/discussion/42847/high-cpu-usage-low-fps-potential-fix/p1

High/100% CPU Usage - Potential workaround 2
  • Only one or two verified cases of this working but... try increasing your memory frequency within your BIOS, the XMP profiles should make this easy. Google search for specific instructions for your motherboard.
  • Overclocking CPUs (especially voltages) has been causing the game to crash. Try downclocking/volting.

Graphical glitches on Aimens (AMD Specific)
  • If you're experiencing large 'sun' like light on your screen (http://i.imgur.com/nmEF0Bf.jpg), or your screen going blue, black or red - try putting your lighting settings on Ultra. You can leave the other settings as they are, it fixed it for me and others but isn't definitive. This won't work if you apply mid game, you'll need to restart first.

Other Tips:
  1. Disable Origin in-game, it's been causing DirectX crashes and is quite buggy right now. You an still alt-tab to accept invites etc. Disable all notifications too as they will minimize your game.
  2. Try running the game in Borderless or Windowed Mode, this has improved FPS for some.
  3. Make sure there is no memory limits in your BF1 advanced settings, either match it to your VRAM or set it to unrestricted.
  4. Toggle DX12 on or off (Windows 10 only), you might see huge gains either way depending on drivers and hardware.
  5. In Windows 10, make sure Xbox GameDVR is disabled. https://goo.gl/EQVfKc
  6. Unpark your cores (Windows 7 and 10) install ParkControl https://bitsum.com/parkcontrol/ Make sure parking is disabled http://i.imgur.com/MfrLUrt.png and hit 'Apply', you may also want to adjust Frequency Scaling so it's always giving 100%, change this http://i.imgur.com/BT0TXfP.png and hit 'Apply'. Bear in mind this will use more power as your CPU won't dynamically alter clock speed.
  7. Please note to force constant max CPU performance (either by setting the Frequency Scaling to 100% in ParkControl, or setting the 'Minimum CPU' state to 100% in your power settings: http://i.imgur.com/cefxdV4.png) you MUST have C1E DISABLED and EIST ENABLED within your BIOS, you should be looking for something like this: http://i.imgur.com/QLHv2pf.jpg (please check the edits at the bottom for more info on power states)
  8. If you have an i7 CPU, make sure Hyperthreading is enabled in your BIOS.
  9. Unplug or disable your second/third monitor. People have reported a 20+ FPS drop just from having a second monitor plugged in.

Other (unverified) Solutions:
  1. Disable Superfetch in Windows http://www.technipages.com/windows-enable-disable-superfetch Do this last, re-enable it if it has no effect.
  2. Windows Audio Device Graph Isolation has caused stutter in Battlefield 4 and other games, you could try turning it off: http://www.howtogeek.com/273764/what-is-windows-audio-device-graph-isolation-and-why-is-it-running-on-my-pc/
  3. If you're using an older overclocked i5/i7 chip (2600k era etc.), you may see some benefits in disabling C3 and C6 power states in your BIOS.




UPDATES

EDIT 2 - Included a better option for managing parked cores/CPU frequency. Please note you shouldn't generally need to unpark cores in Windows 10 but there does seem to be some teething issues for some so try the fix anyway.
EDIT 3 - Updated to include older drivers
EDIT 4 - Added Windows Audio Device Graph Isolation suggestion
EDIT 5 - Added Borderless/Windowed Mode suggestion
EDIT 6 - Updated iformation on CPU power states, for the record C1E means the CPU handles power saving alone - nothing you set in Windows will override this. Enabling EIST means Windows will handle the power.
EDIT 7 - New Drivers from AMD and nVidia.
EDIT 8 - Added potential 100% CPU Fix
EDIT 9 - Possible workaround for light bug on Aimens map
EDIT 10 - Disable Origin Overlay
Post edited by -LIPs-Kashinoda on

Comments

  • Ashby_JC
    494 postsMember, Battlefield 4, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha Member
    Its shadow play ON by default?

    Im not having issues but if turning it off can improve what im getting then great.
  • GustavoFring44
    9 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1 Member
    edited October 2016
    I have the newest geforce experience which is a re-hauled GUI and i dont see anything about shadowplay on there. There is something called nvidia shield?

    Where is this max memory limit setting you are referring to?
  • -LIPs-Kashinoda
    46 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1 Member
    Ashby_JC wrote: »
    Its shadow play ON by default?

    Im not having issues but if turning it off can improve what im getting then great.

    On the most recent drivers it doesn't seem to be on unless you enable it which is maybe why you don't have issues, but I don't have an Nvidia card so can't comment on what the norm is. Not sure why it's causing drops but other recording software has trouble with the BF1 trial too.
  • Aii_Gee
    6 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, BF1IncursionsAlpha, Battlefield V Member
    Ashby_JC wrote: »
    Its shadow play ON by default?

    Im not having issues but if turning it off can improve what im getting then great.

    No it's not.

    You have to specifically enabling the feature "Sharing" in GeForce Experience in order to use Shadowplay.
  • D33N5
    51 postsMember, Battlefield 4, Battlefield, Battlefield 1 Member
    How to turn it off for anyone interested
    https://youtube.com/watch?v=_7ej-SBLpzY
  • -LIPs-Kashinoda
    46 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1 Member
    edited October 2016
    Bump.
    Post edited by -LIPs-Kashinoda on
  • -LIPs-Kashinoda
    46 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1 Member
    Made a lot of updates to this, bump :)
  • Weezy_760
    100 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1 Member
    It really isn't that bad. I recorded some gameplay today using shadowplay and got a quick fps drop that only lasted a second or two. I just recently started playing PC within the last year though so i guess I'm just used to these kind of things because of console.
  • -LIPs-Kashinoda
    46 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1 Member
    It really isn't that bad. I recorded some gameplay today using shadowplay and got a quick fps drop that only lasted a second or two. I just recently started playing PC within the last year though so i guess I'm just used to these kind of things because of console.

    It's bad for some though. People dropping from a solid 60 in the BETA to sub 40 now, and others with Nvidia 1080s that are only hitting 60 when they should be in the hundreds.
  • F1aw1ess
    817 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, BF1IncursionsAlpha, Battlefield V Member
    I have the newest geforce experience which is a re-hauled GUI and i dont see anything about shadowplay on there. There is something called nvidia shield?

    Its called Share, a small icon along the top bar 2 to the left of your login name.


  • -LIPs-Kashinoda
    46 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1 Member
    Bump.
  • SoScary
    21 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, CTE Member
    Where is the DX12 option? I'm getting okay performance but I can't see a DX12 option so I don't know if it's on or off.
  • SilverKidPoweh
    113 postsMember, Battlefield 3, Battlefield Hardline, Battlefield, Battlefield 1, Battlefield V Member
    SoScary wrote: »
    Where is the DX12 option? I'm getting okay performance but I can't see a DX12 option so I don't know if it's on or off.

    I think windows 7 guys dont have this option, i dont have it either
  • Roughneck2-O
    18 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1 Member
    OP et al:

    If parking cores is still a thing, then there's no need to install/run 3rd party programs to access this feature.

    Simply do this:
    Start → Power Options → 'Change plan settings' (for your currently selected Power Plan) → 'Change advanced power settings' and then:
    http://i.imgur.com/cefxdV4.png

    You can verify said claim using either HWMonitor or HWiNFO64.
  • -LIPs-Kashinoda
    46 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1 Member
    OP et al:

    If parking cores is still a thing, then there's no need to install/run 3rd party programs to access this feature.

    Simply do this:
    Start → Power Options → 'Change plan settings' (for your currently selected Power Plan) → 'Change advanced power settings' and then:
    http://i.imgur.com/cefxdV4.png

    You can verify said claim using either HWMonitor or HWiNFO64.

    Yep this will work too, thanks for posting.

    It's a bit fussy on Windows 10, it's meant to change dynamically but it isn't perfect.

  • VonReisler
    572 postsMember, Battlefield 4, Battlefield, Battlefield 1, Battlefield V Member
    only win 10 for dx 12 ,
  • Roughneck2-O
    18 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1 Member
    edited October 2016
    Yep this will work too, thanks for posting.

    It's a bit fussy on Windows 10, it's meant to change dynamically but it isn't perfect.

    A possibility of it being 'fussy' might be related to one's BIOS power-saving settings (C-States and EIST).
    This is how it's set up here: http://i.imgur.com/QLHv2pf.jpg, which translates to:
    (C3 State Support) Voltage drop while idle = Enabled.
    (CPU EIST Function) Frequency drop while idle = Enabled.

    From there, if force the cores to unpark via the 'Power Options' method I've shown above - it overrides the 'Frequency drop while idle' BIOS setting just fine.
  • TheWalkingDerp
    381 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1 Member
    Posted this in another thread, it may be a cause for some people, I only noticed it after crashing randomly to 30ish fps in Shadow Warrior 2:
    Another thing people can try is related to a process called Audio Device Graph Isolation and the Audiodg.exe. This process for some reason laods 20-30% on the CPU. You can safely disable it in the windows task scheduler and restart your PC and it should be gone.

    I couldn't find an english explanation how to do it in the task scheduler so you'll have to google yourself, sorry.

    What seemed to help me as well is limting the frames. Limit them to what you usually hit on average.
  • -LIPs-Kashinoda
    46 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1 Member
    Yep this will work too, thanks for posting.

    It's a bit fussy on Windows 10, it's meant to change dynamically but it isn't perfect.

    A possibility of it being 'fussy' might be related to one's BIOS power-saving settings (C-States and EIST).
    This is how it's set up here: http://i.imgur.com/QLHv2pf.jpg, which translates to:
    (C3 State Support) Voltage drop while idle = Enabled.
    (CPU EIST Function) Frequency drop while idle = Enabled.

    From there, if force the cores to unpark via the 'Power Options' method I've shown above - it overrides the 'Frequency drop while idle' BIOS setting just fine.

    Which one of those relates to parking? I assumed C3 was down to frequency specifically rather than cores being parked within Windows. I'll edit the OP with your information later on anyway!
  • -LIPs-Kashinoda
    46 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1 Member
    Posted this in another thread, it may be a cause for some people, I only noticed it after crashing randomly to 30ish fps in Shadow Warrior 2:
    Another thing people can try is related to a process called Audio Device Graph Isolation and the Audiodg.exe. This process for some reason laods 20-30% on the CPU. You can safely disable it in the windows task scheduler and restart your PC and it should be gone.

    I couldn't find an english explanation how to do it in the task scheduler so you'll have to google yourself, sorry.

    What seemed to help me as well is limting the frames. Limit them to what you usually hit on average.

    I will look into this and add if applicable, thank you.
This discussion has been closed.