Battlefield 1 FPS drops!

Comments

  • feel2death
    21 postsMember, Battlefield 4, Battlefield, Battlefield 1 Member
    i just wanna say thanks for someone in here to sugesting roll back the driver to 378.78 drivers my i7 4790k and 1070 are now playable no more fps drop but still cant get 100fps just 80-60 in ultra so .. thanks
  • HGHertel
    7 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1 Member
    bamboBJJ wrote: »
    Do you suggest then changing mobo?? I would just love to play this game so stable...

    No, I suggest you to disable the AMD-Turbo in the BIOS and let a simple room fan blowing in your opened case. Now the minimum fps should be a little bit lower because of the deactivated Turbo, but should be hold permanently. If it is so, your VRMs overheated and will be the root cause of your fps drops. To solve this, a good top-blowing-fan should be replace your actual one. And, like F1aw1ess already said, a few more GB of RAM should be helpful too.
  • Stormfirebird
    710 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, BF1IncursionsAlpha, Battlefield V Member
    edited July 2017
    feel2death wrote: »
    i just wanna say thanks for someone in here to sugesting roll back the driver to 378.78 drivers my i7 4790k and 1070 are now playable no more fps drop but still cant get 100fps just 80-60 in ultra so .. thanks

    Use MSI Afterburner to display GPU utilization, clocks and temps ingame. If you average closer to 80 it sounds about right though.
  • bamboBJJ
    4 postsMember, Battlefield, Battlefield 1 Member
    HGHertel wrote: »
    bamboBJJ wrote: »
    Do you suggest then changing mobo?? I would just love to play this game so stable...

    No, I suggest you to disable the AMD-Turbo in the BIOS and let a simple room fan blowing in your opened case. Now the minimum fps should be a little bit lower because of the deactivated Turbo, but should be hold permanently. If it is so, your VRMs overheated and will be the root cause of your fps drops. To solve this, a good top-blowing-fan should be replace your actual one. And, like F1aw1ess already said, a few more GB of RAM should be helpful too.

    I have disabled turbo as You mentioned and fps were damn lower it was not even like 40 or 30 but it was stable 20-25.. I have read that maybe the problem is in MOBO because it is not supporting my CPU becuase this mobo is just 95W TDP and FX 8320 is 125W TDP, about top blowing fan I have already one if I understand You correctly and it is not stock by AMD its Aftermarket cooler, it is annoying problem. Also when I disabled turbo GPU max usage was at 40% max and cpu was 80-100%, strange thing...
  • GoneKeyboard
    51 postsMember, Battlefield 4, Battlefield, Battlefield 1 Member
    Does the new nvidia driver fixed the issue?
  • RealAshWilliams
    419 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha, Battlefield V Member
    I changed my gpu (GTX 1080) for a GTX 1080Ti, so I test with Creator Update : return of the problems.
    So tomorrow, I again formate, and again installation windows without Creator Update, seriously.....
  • okot3
    34 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha, Battlefield V Member
    edited July 2017
    play 3 match today, two first no one stuttering but 3 i get more stutter's, damn i dont ¯\_(ツ)_/¯ now wtf with bf1! it's nvidia? windows 10 cu? or dice, damm i dont know what do now, gtx 1070 / i7 6700k / 16 gb / 378.78

    i tested new driver's, dont help
  • 0n3Gun3R
    414 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1 Member
    Ive found turning off page file helps even on SSD make sure you have at least 16GB ram before doing so.

    I have 2 samsung pro SSD in RAID 0 with 1GB r/w still happens till i turn off pagefile.
  • TheOneBellagio
    7 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1 Member
    I see Nvidia release new Drivers, now the situation is improved?
  • XiQxB3astzXII
    2 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1 Member
    i got a gtx 1060 and an i7 7700hq game is running smoothly around 77-65 fps on ultra settings but i only recently got those weird fps drops in multiplayer to sometimes even 25 fps really annoying cor could it be that 8 gb of ddr4 ram are not enough for the game ??
  • GoneKeyboard
    51 postsMember, Battlefield 4, Battlefield, Battlefield 1 Member
    i got a gtx 1060 and an i7 7700hq game is running smoothly around 77-65 fps on ultra settings but i only recently got those weird fps drops in multiplayer to sometimes even 25 fps really annoying cor could it be that 8 gb of ddr4 ram are not enough for the game ??

    Yeah 8GB is NOT enough for ultra.
  • flep
    11 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1 Member
    edited August 2017
    After extend research and a lot of tests, here is what I found useful and a few info to stop some misconception:

    - BF1 uses a lot of CPU, so you need it to be at full Mhz at all times when playing. But you don't need to unpark your processors, specially using some third party software. "Parking" is just another way to refer to CPU C1E / Intel SpeedStep, which is basically an useful feature that makes your CPU run on a lower clock when you don't need it, which is great for saving some power and also making your CPU last longer specially if you overclock. (If you still want to do it, just go into your bios and disable C1E / Intel SpeedStep)

    - So in order to make sure during BF1 your CPU doesn't go bellow maximum Mhz (i'm refering to frequency not usage) what you simple need to do is go into your power plans (Control Panel\All Control Panel Items\Power Options) and edit a plan (or create a new one), go into "change plan settings" then "Change advanced power settings", go into Processor Power management > Minimum processor state and set it to 100%. Save the plan and activate it when you are playing, so SpeedStep doesn't kick in randomly during the game, which is a cause of stuttering / FPS drop on BF1.

    - There is a few settings on BF1 that REALLY consume CPU power and IMO doesn't add anything to the experience at all, you really don't see a difference when running around killing people on a fast paced game like this. A gold tip I learned after so many years as a gamer is that "putting all on Ultra" is always, always a bad decision.

    So after testing a lot and researching a lot I found the settings below to be the ones that on ALL SYSTEMS can create huge FPS drops / stuttering making the experience terrible. Even if you have a super PC try to use them and see, you probably wont note any visually different during actual gameplay and it may boost your FPS / game stability by a lot.

    (Those settings are meant to be placed on a user.cfg on your BF1 directory, and remove the comments)

    RenderDevice.RenderAheadLimit 2
    GameTime.MaxVariableFps 85
    Thread.ProcessorCount 4 //Change this to the number of cores your processor have
    Thread.MaxProcessorCount 4 //Change this to the number of cores your processor have
    Thread.MinFreeProcessorCount 0
    WorldRender.MotionBlurEnable 0
    WorldRender.MotionBlurRadialBlurMax 0
    WorldRender.MotionBlurQuality 0
    WorldRender.MotionBlurMaxSampleCount 0
    WorldRender.MotionBlurForceOn 0
    WorldRender.MotionBlurFixedShutterTime 0
    WorldRender.MotionBlurMax 0
    WorldRender.MotionBlurEnabled 0
    WorldRender.SpotLightShadowmapEnable 0
    WorldRender.SpotLightShadowmapResolution 256
    WorldRender.TransparencyShadowmapsEnable 0

    The MaxVariableFps settings is up to you, but is needed so the CPU doesn't have problems if the FPS goes up too high. If you have a 60hz monitor limit it to 60.

    Ideally you need to tweak the FPS limit with your needs and the in-game settings you want to use. I play with a i5 3570K @ 4.6Ghz and a GTX 980 TI on 1440p/144hz monitor. BF1 has great visuals on mid too, so besides the textures and terrain details that I have a mix of high/ultra, the rest I use on mid and really don't see a difference from mid to ultra besides a huge hit on FPS. (PS: I personally don't like Blur so I have it off in game too, but you probably figured out already that Blur is a huge BS that just eat your power resources on games).

    Before any of the changes above (and the power plan stuff which is needed) my system was just not handling the game not even on low settings on some maps, going from 100 FPS to 30 and stuttering all over the place, with my CPU locked at 100% use at all times.
    After I tweaked all this I can now play at 80 / 100 FPS at all times even on the heavy maps, and my CPU use is always at 98~100 (which is OK, what is not ok is to be locked at 100 which is a clear sign that you are above the limit, which introduces stuttering)

    One last tip: depending of your PC / GPU combo you may need to use RenderDevice.RenderAheadLimit 1, but ideally try to use it 2 and lower the in-game settings and limit the FPS, as a value of 1 will limit your CPU usage to ~ 70%. It will eliminate stuttering but will give you lower fps and can introduce input lag.

    That's it, I hope this helps someone =)



    Post edited by flep on
  • perrynoid
    3 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE Member
    I can't seem to find the user.cfg file... did EA change the name of it or do away with it somehow?
  • xenome111
    3064 postsMember, Battlefield 4, Battlefield, Battlefield 1 Member
    edited August 2017
    perrynoid wrote: »
    I can't seem to find the user.cfg file... did EA change the name of it or do away with it somehow?

    U have to create it.
    Create a notepad or text file then change the name to user. cfg (note cfg is the extension if u don't have permission to change extensions then u have to grant permission to do so)
    Put the commands in there and save.
  • FISHY12542
    294 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, Battlefield V Member
    flep wrote: »
    After extend research and a lot of tests, here is what I found useful and a few info to stop some misconception:

    - BF1 uses a lot of CPU, so you need it to be at full Mhz at all times when playing. But you don't need to unpark your processors, specially using some third party software. "Parking" is just another way to refer to CPU C1E / Intel SpeedStep, which is basically an useful feature that makes your CPU run on a lower clock when you don't need it, which is great for saving some power and also making your CPU last longer specially if you overclock. (If you still want to do it, just go into your bios and disable C1E / Intel SpeedStep)

    - So in order to make sure during BF1 your CPU doesn't go bellow maximum Mhz (i'm refering to frequency not usage) what you simple need to do is go into your power plans (Control Panel\All Control Panel Items\Power Options) and edit a plan (or create a new one), go into "change plan settings" then "Change advanced power settings", go into Processor Power management > Minimum processor state and set it to 100%. Save the plan and activate it when you are playing, so SpeedStep doesn't kick in randomly during the game, which is a cause of stuttering / FPS drop on BF1.

    - There is a few settings on BF1 that REALLY consume CPU power and IMO doesn't add anything to the experience at all, you really don't see a difference when running around killing people on a fast paced game like this. A gold tip I learned after so many years as a gamer is that "putting all on Ultra" is always, always a bad decision.

    So after testing a lot and researching a lot I found the settings below to be the ones that on ALL SYSTEMS can create huge FPS drops / stuttering making the experience terrible. Even if you have a super PC try to use them and see, you probably wont note any visually different during actual gameplay and it may boost your FPS / game stability by a lot.

    (Those settings are meant to be placed on a user.cfg on your BF1 directory, and remove the comments)

    RenderDevice.RenderAheadLimit 2
    GameTime.MaxVariableFps 100
    Thread.ProcessorCount 4 //Change this to the number of cores your processor have
    Thread.MaxProcessorCount 4 //Change this to the number of cores your processor have
    Thread.MinFreeProcessorCount 0
    WorldRender.MotionBlurEnable 0
    WorldRender.MotionBlurRadialBlurMax 0
    WorldRender.MotionBlurQuality 0
    WorldRender.MotionBlurMaxSampleCount 0
    WorldRender.MotionBlurForceOn 0
    WorldRender.MotionBlurFixedShutterTime 0
    WorldRender.MotionBlurMax 0
    WorldRender.MotionBlurEnabled 0
    WorldRender.SpotLightShadowmapEnable 0
    WorldRender.SpotLightShadowmapResolution 256
    WorldRender.TransparencyShadowmapsEnable 0

    The MaxVariableFps settings is up to you, but is needed so the CPU doesn't have problems if the FPS goes up too high. If you have a 60hz monitor limit it to 60.

    Ideally you need to tweak the FPS limit with your needs and the in-game settings you want to use. I play with a i5 3570K @ 4.6Ghz and a GTX 980 TI on 1440p/144hz monitor. BF1 has great visuals on mid too, so besides the textures and terrain details that I have a mix of high/ultra, the rest I use on mid and really don't see a difference from mid to ultra besides a huge hit on FPS. (PS: I personally don't like Blur so I have it off in game too, but you probably figured out already that Blur is a huge BS that just eat your power resources on games).

    Before any of the changes above (and the power plan stuff which is needed) my system was just not handling the game not even on low settings on some maps, going from 100 FPS to 30 and stuttering all over the place, with my CPU locked at 100% use at all times.
    After I tweaked all this I can now play at 80 / 100 FPS at all times even on the heavy maps, and my CPU use is always at 98~100 (which is OK, what is not ok is to be locked at 100 which is a clear sign that you are above the limit, which introduces stuttering)

    One last tip: depending of your PC / GPU combo you may need to use RenderDevice.RenderAheadLimit 1, but ideally try to use it 2 and lower the in-game settings and limit the FPS, as a value of 1 will limit your CPU usage to ~ 70%. It will eliminate stuttering but will give you lower fps and can introduce input lag.

    That's it, I hope this helps someone =)



    Dude this all helped a ton! But..even with RenderAheadLimit set to 2 I got some input lag (like it only happens near combat..like my mouse just acts really stiff and doesn't wanna move). What should I do to fix this?
  • LOLGotYerTags
    14360 postsMember, Moderator, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha, Battlefield V Moderator
    FISHY12542 wrote: »

    Dude this all helped a ton! But..even with RenderAheadLimit set to 2 I got some input lag (like it only happens near combat..like my mouse just acts really stiff and doesn't wanna move). What should I do to fix this?

    Change it from 2 to 1 :)
  • FISHY12542
    294 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, Battlefield V Member
    FISHY12542 wrote: »

    Dude this all helped a ton! But..even with RenderAheadLimit set to 2 I got some input lag (like it only happens near combat..like my mouse just acts really stiff and doesn't wanna move). What should I do to fix this?

    Change it from 2 to 1 :)

    I'll give it a shot :).
  • B0ng0_Banger
    1161 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, Battlefield V Member
    flep wrote: »
    After extend research and a lot of tests, here is what I found useful and a few info to stop some misconception:

    - BF1 uses a lot of CPU, so you need it to be at full Mhz at all times when playing. But you don't need to unpark your processors, specially using some third party software. "Parking" is just another way to refer to CPU C1E / Intel SpeedStep, which is basically an useful feature that makes your CPU run on a lower clock when you don't need it, which is great for saving some power and also making your CPU last longer specially if you overclock. (If you still want to do it, just go into your bios and disable C1E / Intel SpeedStep)

    - So in order to make sure during BF1 your CPU doesn't go bellow maximum Mhz (i'm refering to frequency not usage) what you simple need to do is go into your power plans (Control Panel\All Control Panel Items\Power Options) and edit a plan (or create a new one), go into "change plan settings" then "Change advanced power settings", go into Processor Power management > Minimum processor state and set it to 100%. Save the plan and activate it when you are playing, so SpeedStep doesn't kick in randomly during the game, which is a cause of stuttering / FPS drop on BF1.

    - There is a few settings on BF1 that REALLY consume CPU power and IMO doesn't add anything to the experience at all, you really don't see a difference when running around killing people on a fast paced game like this. A gold tip I learned after so many years as a gamer is that "putting all on Ultra" is always, always a bad decision.

    So after testing a lot and researching a lot I found the settings below to be the ones that on ALL SYSTEMS can create huge FPS drops / stuttering making the experience terrible. Even if you have a super PC try to use them and see, you probably wont note any visually different during actual gameplay and it may boost your FPS / game stability by a lot.

    (Those settings are meant to be placed on a user.cfg on your BF1 directory, and remove the comments)

    RenderDevice.RenderAheadLimit 2
    GameTime.MaxVariableFps 100
    Thread.ProcessorCount 4 //Change this to the number of cores your processor have
    Thread.MaxProcessorCount 4 //Change this to the number of cores your processor have
    Thread.MinFreeProcessorCount 0
    WorldRender.MotionBlurEnable 0
    WorldRender.MotionBlurRadialBlurMax 0
    WorldRender.MotionBlurQuality 0
    WorldRender.MotionBlurMaxSampleCount 0
    WorldRender.MotionBlurForceOn 0
    WorldRender.MotionBlurFixedShutterTime 0
    WorldRender.MotionBlurMax 0
    WorldRender.MotionBlurEnabled 0
    WorldRender.SpotLightShadowmapEnable 0
    WorldRender.SpotLightShadowmapResolution 256
    WorldRender.TransparencyShadowmapsEnable 0

    The MaxVariableFps settings is up to you, but is needed so the CPU doesn't have problems if the FPS goes up too high. If you have a 60hz monitor limit it to 60.

    Ideally you need to tweak the FPS limit with your needs and the in-game settings you want to use. I play with a i5 3570K @ 4.6Ghz and a GTX 980 TI on 1440p/144hz monitor. BF1 has great visuals on mid too, so besides the textures and terrain details that I have a mix of high/ultra, the rest I use on mid and really don't see a difference from mid to ultra besides a huge hit on FPS. (PS: I personally don't like Blur so I have it off in game too, but you probably figured out already that Blur is a huge BS that just eat your power resources on games).

    Before any of the changes above (and the power plan stuff which is needed) my system was just not handling the game not even on low settings on some maps, going from 100 FPS to 30 and stuttering all over the place, with my CPU locked at 100% use at all times.
    After I tweaked all this I can now play at 80 / 100 FPS at all times even on the heavy maps, and my CPU use is always at 98~100 (which is OK, what is not ok is to be locked at 100 which is a clear sign that you are above the limit, which introduces stuttering)

    One last tip: depending of your PC / GPU combo you may need to use RenderDevice.RenderAheadLimit 1, but ideally try to use it 2 and lower the in-game settings and limit the FPS, as a value of 1 will limit your CPU usage to ~ 70%. It will eliminate stuttering but will give you lower fps and can introduce input lag.

    That's it, I hope this helps someone =)



    to early to tell since the stuttering was totally random for me but since adding these commands I've had no fps drops at all. I'm still certain it's a game/server problem and needs looking in to by the devs.
  • perrynoid
    3 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE Member
    edited August 2017
    xenome111 wrote: »
    perrynoid wrote: »
    I can't seem to find the user.cfg file... did EA change the name of it or do away with it somehow?

    U have to create it.
    Create a notepad or text file then change the name to user. cfg (note cfg is the extension if u don't have permission to change extensions then u have to grant permission to do so)
    Put the commands in there and save.

    Ok, so I did as you directed. there seems to be some improvement but, I still get random frame drops that make it almost unplayable at times. what else do you recommend?
    my hardware:
    Ryzen 5 1600x (stock clock)
    MSI M320 gaming MB
    MSI RX 580 8GB gaming video card with stock overclock enabled
    16 GB DDR4 2400 low latency (stock clock and voltage)
    I'm running the game on a 1440p 60 htz monitor over DVI
    I have all the latest drivers
    I have enabled enhanced sync in the Radeon settings
    my power plan is set to max performance
    seems to have similar problems running in DX 11 or 12
    Lowering my settings in game seems to improve overall average frame rate but does not prevent to crippling random dips and stuttering.
    Thanks in advance.

    Post edited by perrynoid on
  • xcasxcursex
    1676 postsMember, Battlefield 4, Battlefield, Battlefield 1, CTE, Battlefield V Member
    edited August 2017
    RenderDevice.RenderAheadLimit 2
    Is the default
    GameTime.MaxVariableFps 100
    Differs per user
    Thread.ProcessorCount 4 //Change this to the number of cores your processor have
    Thread.MaxProcessorCount 4 //Change this to the number of cores your processor have
    Thread.MinFreeProcessorCount 0
    Now you have set up your PC so that the game will use ALL of your CPU and leave none for things like the operating system.
    WorldRender.MotionBlurEnable 0
    WorldRender.MotionBlurRadialBlurMax 0
    WorldRender.MotionBlurQuality 0
    WorldRender.MotionBlurMaxSampleCount 0
    WorldRender.MotionBlurForceOn 0
    WorldRender.MotionBlurFixedShutterTime 0
    WorldRender.MotionBlurMax 0
    WorldRender.MotionBlurEnabled 0
    You can disable motion blur in the menus now, and most of these are for BF3 or BF4 but not BF1.
    WorldRender.SpotLightShadowmapEnable
    You're not even setting anything here
    WorldRender.SpotLightShadowmapResolution 256
    WorldRender.TransparencyShadowmapsEnable 0
    And you just made smoke more blinding for practically no performance change.
    That's it, I hope this helps someone =)
    I hope you will learn to understand and properly test settings you are changing and not just recommend things that don't work, to everyone.

Sign In or Register to comment.