Weekly BF

No emblems appear.

2»

Comments

  • TrueEmissary
    28 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1 Member
    edited May 2018
    No, i haven't used it at all and miss my emblem too.

    edit: I was of course talking about the companion app.
  • walkmantr
    1 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield Member
    Go to "C:\Users\*yourname*\Documents\Battlefield 4" and delete the Twinkle folder and relaunch.

    It happens sometimes.

    I did. but it did not work.
  • thegrizz72
    150 postsMember, Battlefield 3, Battlefield 4, Battlefield Member
    Don't use it and have the issue as does everyone that plays on our server.
  • Absynthe81
    5 postsMember, Battlefield 3, Battlefield 4, Battlefield Member
    edited May 2018
    thegrizz72 wrote: »
    Don't use it and have the issue as does everyone that plays on our server.

    hmmm so it's not just people who've used web companion then. Well seems like EA/DICE broke BF4 in game code to do with emblems whilst trying to implement compatibility for web companion but broke compatibility with battlelog emblems at the same time... :/

    Only consolation is it's not an issue to fix on our end. :* The thing is all we can do now is report the bug and wait until EA/DICE get their act together to fix it... Who knows how long that would be since it's not game breaking (so probably low priority...) but annoying all the same. :'(
  • Clems-First
    7 postsMember, Battlefield 3, Battlefield 4, Battlefield Member
    edited May 2018
    It seems that you need to remove the emblem you are using on the Battlefield 4 site.
    Create a new emblem with something in it and then "use" and then remove the emblem without "using" any other emblem.
    Go to the Battlefield Companion and finally equip your emblem. You join the game and you should see the emblems.
    I have no idea why it works, but that's how it worked for me.
    Post edited by Clems-First on
  • Il-Scavenger-lI
    901 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha Member
    edited May 2018
    Gonna try now.
    .
    Edit: nuffin :(
  • Clems-First
    7 postsMember, Battlefield 3, Battlefield 4, Battlefield Member
    Gonna try now.
    .
    Edit: nuffin :(

    Did it work once (one round) ?
    Try joining the CHE GUEVARA server. It works fine for me there (Hardcore TDM server)
  • Il-Scavenger-lI
    901 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha Member
    edited May 2018
    Gonna try now.
    .
    Edit: nuffin :(

    Did it work once (one round) ?
    Try joining the CHE GUEVARA server. It works fine for me there (Hardcore TDM server)
    No, still didn't show it.
    .
    Will test it on that server tonight.
  • EXILE157
    236 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, Battlefield V Member
    edited May 2018
    I'll post this up with the EA team and see if theres anything they suggest
    Please do because it seems to be everyone having the issue, so it has to be something on EA/DICE side. Maybe during the XP weekend setup or BF1 Companion crap App did this....

  • thegrizz72
    150 postsMember, Battlefield 3, Battlefield 4, Battlefield Member
    Emblems were back on our server today.
  • Il-Scavenger-lI
    901 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha Member
    thegrizz72 wrote: »
    Emblems were back on our server today.

    Yesterday evening my emblem was back. Now it is gone again :/
  • Clems-First
    7 postsMember, Battlefield 3, Battlefield 4, Battlefield Member
  • Absynthe81
    5 postsMember, Battlefield 3, Battlefield 4, Battlefield Member

    It's not really fixed if it only works on a hand full of servers. Plus that server isn't in my region so it's **** poor ping for me if I play there.
    thegrizz72 wrote: »
    Emblems were back on our server today.

    Is it still working or have they disappeared again?

    Maybe servers needs to be reset? If that doesn't work it def needs to be fixed on EA/DICE side.
  • TrueEmissary
    28 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1 Member
    On a couple of servers they work and on the rest of my favs, they don't. Strange....
  • Il-Scavenger-lI
    901 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha Member
    My emblem is back now :) Played yesterday evening and this morning.
  • TrueEmissary
    28 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1 Member
    Still the same. On a couple of servers they appear, unfortunaly on most of my favs, they don't.
  • SHEMALES_FOREVER
    3 postsMember, Battlefield 4, Battlefield Member
    yes,IT HAPPENS
  • EXILE157
    236 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, Battlefield V Member
    Always breaking something and then acting as if nothing happen. It’s not EA/DICE concern anymore, its all about selling BFV now.
  • Absynthe81
    5 postsMember, Battlefield 3, Battlefield 4, Battlefield Member
    Seems to be fixed now... Most the servers I play on are now displaying custom emblems again :D
  • EXILE157
    236 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, Battlefield V Member
    Absynthe81 wrote: »
    Seems to be fixed now... Most the servers I play on are now displaying custom emblems again :D

    Yeah, is back on!
Sign In or Register to comment.