First and last straw almost has me walking away - EA, Dice, Anyone? Please acknowledge

LanceKilkenny65
104 postsMember, Battlefield, Battlefield 1, CTE, Battlefield V Member
This started for me when the beta started. It was also happening about 3 weeks ago as well. I restarted all of my network equipment and rebooted my xbox 1 (not s or x). I can not finish a game in Battlefield 1, i get about 10 minutes in and get disconnected.

I have a 100mbps connection down and a 10mbps connecton up through midcontinent (comcast) cable in Mandan, ND

I have zero issues streaming Ultra High Def 4K programming

I have nothing else sucking up bandwidth

During the beta i joined 30-50 games, i was probably able to complete 2 in V. A few more in 1

I have 800+ hours into BF1 and typically place in the top 1/3 so i am not a great player but probably better than average, but also rarely in the top 5

All of this was achieved with a typical latency (lately of about 68-72) it does not matter if i am wired or wireless... before then, it was in the high 70's to low 90's and i had very few issues unless everyone else was having issues.

I loved the beta, but cancelled my pre-order based on this aggravation. After seeing the other beta feedback, i think battlefield v is going to be a harder sell than it should be. This connection issue was the last straw for me. Based on that, Battlefiled 1 needs to be playable for awhile at least if you want to continue as being my gaming provider.

So, EA; if you have changed your latency requirements. Fine...just let us know what the minimum is, so we can make an informed decision. I see the other latency's and can't imagine how it could be that drastically different in this day and age...perhaps yo need to deploy some servers in the midwest.

The first straw is the St***pid F***ing team balancing! It needs to stop and it needs to be put back the way it was. I am not a gambler, but if i were playing the roulette wheel in Vegas and i told the wheel guy to put my money on black and he just randomly decided to move me to red and i lost, there would be blood shooting out of my eyes! And another thing, YOU set up for us these ribbon requirements and assignments that require that we play as a french soldier to do this and then switch us to the other team? This sucks!!! Try switching players around on an NFL team and see how that would work out for you.

If i can ever get on to play again and i am on defense and get switched to offense and i can't switch back - i quit
if i am in a squad i am really clicking with and get switched to the other team without my squad and can't switch back - i quit

Is it just me or are these two things plaguing others?

Comments

  • LanceKilkenny65
    104 postsMember, Battlefield, Battlefield 1, CTE, Battlefield V Member
    Hi there,
    You asked us to cancel all or part of your order. We did, and didn't charge you for those things.
    It may take up to 24 hours before it's reflected on our website, so don't worry if your order info doesn't appear updated right away.
    Hope to see you in the store again soon!

  • LanceKilkenny65
    104 postsMember, Battlefield, Battlefield 1, CTE, Battlefield V Member
    So no one is going to do anything about the ¯\_(ツ)_/¯ servers?
  • StingX71
    828 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha, Battlefield V Member
    edited September 2018
    Beta squad/team switching was fubared. I hardly ever get disconnected from a game on Xbox or PC. Do you have your xbox in DMZ mode in your router? Might give you a cleaner path to the servers. Could still be an issue with your router. Make sure UPnP (router setting) is on as well.
  • LanceKilkenny65
    104 postsMember, Battlefield, Battlefield 1, CTE, Battlefield V Member
    Here's the thing... I have 950+ hours into this game with the same router and setup... basically out of the box xbox settings on wireless no less. This started a day before or the day of the beta. It happened previously once but a simple reboot of router and modem fix that.

    Here are my stats as reported by xbox console: 91.9 mbps downn 7.7 up Packet loss 0% MTU 1480 Latency 77ms typically during those 950 plus hours on wireless my latency was less than 90 and more likely (90% of the time) under 75. I typically play operations.

    I have given my xbox a static IP I put it in DMZ. Its mtu is set to 1480. I tried 8.8.8.8 and 8.8.4.4 for dns, as well as 1.1.1.1 and 1.0.0.1 as well as my ISP's DNS and the 1.1.1.1 gave about a point better than google, which was about a point better than my ISP which is midco (essentially comcast for the midwest)

    My Nat type on router and xbox is open for the DMZ..... I do have the CD in tray so cleared the Blue Ray saved data, I did the Mac Reset thing. I even hooked up a hard wire cable for internet. NONE of this was necessary previously and it is not helping anyway.....

    Something on EA's end code or Servers changed..... Plain and simple.... I even turned on the annoying graph and it pretty much shows flat lines running across during play and even with a 67 latency...crash and burn... spawn in a tank crash and burn (that was on the first dessert map)... playing along as soissons... boom crash and burn... Shooting at a plane with an aa gun .... plane stops in mid air...gun keeps firing ...crash and burn. Jump into an airship... only the two end slots and driver slot are open... no damage... no weapons firing. Something Changed!

    <iframe src="https://onedrive.live.com/embed?¯\_(ツ)_/¯=FC24E1219CB2DBE4&resid=FC24E1219CB2DBE4%21636&authkey=APyVLbzciPmw5uY" width="320" height="180" frameborder="0" scrolling="no" allowfullscreen></iframe>
  • RetroGMR083
    51 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, Battlefield V Member
    edited September 2018
    It's not just you OP, I get problems too and like you, I'm given a runaround. Sometimes I would be disconnected mid-game. But now for months, the server browser doesn't work as it's supposed to. Having all maps selected gives me only around three, four maps and they're all the same. So, 45 results for conquest gives me three to four maps exactly the same 45 times! Honestly, with all of the problems that's been going on, I wouldn't be surprised if a Class Action Lawsuit is brought against EA & DICE. It's happened before and it can happen again. They deserve to be sued. A multi-billion dollar company is so arrogant, negligent and operates like a third world country.
  • LanceKilkenny65
    104 postsMember, Battlefield, Battlefield 1, CTE, Battlefield V Member
    Here's the thing... I have 950+ hours into this game with the same router and setup... basically out of the box xbox settings on wireless no less. This started a day before or the day of the beta. It happened previously once but a simple reboot of router and modem fix that.

    Here are my stats as reported by xbox console: 91.9 mbps downn 7.7 up Packet loss 0% MTU 1480 Latency 77ms typically during those 950 plus hours on wireless my latency was less than 90 and more likely (90% of the time) under 75. I typically play operations.

    I have given my xbox a static IP I put it in DMZ. Its mtu is set to 1480. I tried 8.8.8.8 and 8.8.4.4 for dns, as well as 1.1.1.1 and 1.0.0.1 as well as my ISP's DNS and the 1.1.1.1 gave about a point better than google, which was about a point better than my ISP which is midco (essentially comcast for the midwest)

    My Nat type on router and xbox is open for the DMZ..... I do have the CD in tray so cleared the Blue Ray saved data, I did the Mac Reset thing. I even hooked up a hard wire cable for internet. NONE of this was necessary previously and it is not helping anyway.....

    Something on EA's end code or Servers changed..... Plain and simple.... I even turned on the annoying graph and it pretty much shows flat lines running across during play and even with a 67 latency...crash and burn... spawn in a tank crash and burn (that was on the first dessert map)... playing along as soissons... boom crash and burn... Shooting at a plane with an aa gun .... plane stops in mid air...gun keeps firing ...crash and burn. Jump into an airship... only the two end slots and driver slot are open... no damage... no weapons firing. Something Changed!

    <iframe src="https://onedrive.live.com/embed?¯\_(ツ)_/¯=FC24E1219CB2DBE4&resid=FC24E1219CB2DBE4%21636&authkey=APyVLbzciPmw5uY" width="320" height="180" frameborder="0" scrolling="no" allowfullscreen></iframe>
  • LanceKilkenny65
    104 postsMember, Battlefield, Battlefield 1, CTE, Battlefield V Member
    Did something get fixed? I have done nothing different but connectivity has been good the last 36 hours... if you did something EA, THANK YOU! I did nothing different.
  • The-Monz
    72 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, Battlefield V Member
    I doubt anything got fixed.More likely to be your network.Having fast internet doesn't mean stable internet.
  • iAmAnonymousTom
    68 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, Battlefield V Member
    It's DICE. They're an awful developer, as proven by this game and Battlefront II's past and current issues.
  • moosehunter1969
    1108 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, Battlefield V Member
    It's DICE. They're an awful developer, as proven by this game and Battlefront II's past and current issues.
    You don’t have to buy their products you know.
Sign In or Register to comment.