twitching screen after March update

ps_865
359 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, Battlefield V Member
edited April 1
Since the latest Mar update, my screen randomly jitters left, right, a bit up, especially when I run. The movements are not big, like few degrees, but enough to offset your aiming when it happens at that time. In the beginning I thought it was a teammate next to me pushing me left or right.

I don't think this is a classic lag thing due to the high ping, because, with the lag I would see the players jump few meters. This movements are equivalent to me doing it (but I don't). BTW, my ping is around 30. I hope I explained it well

Am I alone, or anyone else experienced this?

Comments

  • TamKingski
    1743 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, Battlefield V Member
    This sounds like the server is trying to determine your position on the server which can cause jitter or rubber banding resulting in your player model jittering or being teleported back to your last position whenever you try to move.

    This can be caused by the server being stressed,but the main culprit is mostly the users own internet connection having some issues or having an issues at that particular moment,packet loss seems to be the main culprit in most of these issues.

    My suggestion would be to ensure you have all the correct ports on your router/modem open for gaming traffic,always use a wired connection if you can and check that your routers built in firewall isnt also blocking traffic.

    If you dont usually have these problems in bfv and these problems suddenly appeared a reboot of your router/modem could be all thats needed to fix the issue.

    If the problem doesnt go away i would suggest you record some gameplay footage with the ingame netgraph showing by using the ps4s built in capture card and post the footage here. Theres a few in the community who can help you troubleshoot if you show some gameplay footage with the netgraph turned on.

    Good luck,hope you get it sorted.
  • ps_865
    359 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, Battlefield V Member
    TamKingski wrote: »
    This sounds like the server is trying to determine your position on the server which can cause jitter or rubber banding resulting in your player model jittering or being teleported back to your last position whenever you try to move.

    This can be caused by the server being stressed,but the main culprit is mostly the users own internet connection having some issues or having an issues at that particular moment,packet loss seems to be the main culprit in most of these issues.

    My suggestion would be to ensure you have all the correct ports on your router/modem open for gaming traffic,always use a wired connection if you can and check that your routers built in firewall isnt also blocking traffic.

    If you dont usually have these problems in bfv and these problems suddenly appeared a reboot of your router/modem could be all thats needed to fix the issue.

    If the problem doesnt go away i would suggest you record some gameplay footage with the ingame netgraph showing by using the ps4s built in capture card and post the footage here. Theres a few in the community who can help you troubleshoot if you show some gameplay footage with the netgraph turned on.

    Good luck,hope you get it sorted.

    thanks for the input. I totally agree with you if it was the network issue, but I found the problem, it is my DS Sony controller. It was a coincidence that it broke down at the time of the last BFV update. I replaced it and the problem is gone. I'll delete this thread in a day or two
  • TamKingski
    1743 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, Battlefield V Member
    ps_865 wrote: »
    TamKingski wrote: »
    This sounds like the server is trying to determine your position on the server which can cause jitter or rubber banding resulting in your player model jittering or being teleported back to your last position whenever you try to move.

    This can be caused by the server being stressed,but the main culprit is mostly the users own internet connection having some issues or having an issues at that particular moment,packet loss seems to be the main culprit in most of these issues.

    My suggestion would be to ensure you have all the correct ports on your router/modem open for gaming traffic,always use a wired connection if you can and check that your routers built in firewall isnt also blocking traffic.

    If you dont usually have these problems in bfv and these problems suddenly appeared a reboot of your router/modem could be all thats needed to fix the issue.

    If the problem doesnt go away i would suggest you record some gameplay footage with the ingame netgraph showing by using the ps4s built in capture card and post the footage here. Theres a few in the community who can help you troubleshoot if you show some gameplay footage with the netgraph turned on.

    Good luck,hope you get it sorted.

    thanks for the input. I totally agree with you if it was the network issue, but I found the problem, it is my DS Sony controller. It was a coincidence that it broke down at the time of the last BFV update. I replaced it and the problem is gone. I'll delete this thread in a day or two

    Haha no worries,glad you got to the bottom of the issue. Happy gaming :)
Sign In or Register to comment.