Weekly BF

[Megathread] Performance issues/Stutter BF5 - PC

Comments

  • Tuco_Ramirez_1
    219 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, BF1IncursionsAlpha, Battlefield V Member
    Did you fix yours freakslade? You mentioned in the other thread about using fiercebrosnans settings. What were they and did they work?
  • FierceBrosnan007
    1016 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha, Battlefield V Member
    Did you fix yours freakslade? You mentioned in the other thread about using fiercebrosnans settings. What were they and did they work?

    Sorry guys busy with work and I didn't get to respond to the other thread. There appears to be something up with the games settings after a patch and installing a new driver. I too had unusually high cpu usage same as others but manage to cure it totally by first downloading the hotfix driver. After doing so I reset the video settings in game to default. Set to dx 12 and FFR off. Restarted the game. Then chose my custom settings in video options and made sure V sync was off, motion blur 1%, framerate limiter - monitor refreshrate and gpu memory restriction OFF.

    The thing which I think made the most impact was hitting reset on the video settings after the hotfix driver installed. No more 90%+ cpu. Back to 65-75% and the game is good to play again. Gpu usage back in high 90s.

    Haven't tried the latest driver yet. Might just stay on the hotfix one since things are working.
  • Tuco_Ramirez_1
    219 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, BF1IncursionsAlpha, Battlefield V Member
    edited May 10
    Did you fix yours freakslade? You mentioned in the other thread about using fiercebrosnans settings. What were they and did they work?

    Sorry guys busy with work and I didn't get to respond to the other thread. There appears to be something up with the games settings after a patch and installing a new driver. I too had unusually high cpu usage same as others but manage to cure it totally by first downloading the hotfix driver. After doing so I reset the video settings in game to default. Set to dx 12 and FFR off. Restarted the game. Then chose my custom settings in video options and made sure V sync was off, motion blur 1%, framerate limiter - monitor refreshrate and gpu memory restriction OFF.

    The thing which I think made the most impact was hitting reset on the video settings after the hotfix driver installed. No more 90%+ cpu. Back to 65-75% and the game is good to play again. Gpu usage back in high 90s.

    Haven't tried the latest driver yet. Might just stay on the hotfix one since things are working.

    Will try this later and let you know how it goes.
    Thanks for the advice. Much appreciated.

    Out of interest what gpu & cpu do you have?

    I've i5 8400
    1070ti
    16gb ddr4
  • FierceBrosnan007
    1016 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha, Battlefield V Member
    Did you fix yours freakslade? You mentioned in the other thread about using fiercebrosnans settings. What were they and did they work?

    Sorry guys busy with work and I didn't get to respond to the other thread. There appears to be something up with the games settings after a patch and installing a new driver. I too had unusually high cpu usage same as others but manage to cure it totally by first downloading the hotfix driver. After doing so I reset the video settings in game to default. Set to dx 12 and FFR off. Restarted the game. Then chose my custom settings in video options and made sure V sync was off, motion blur 1%, framerate limiter - monitor refreshrate and gpu memory restriction OFF.

    The thing which I think made the most impact was hitting reset on the video settings after the hotfix driver installed. No more 90%+ cpu. Back to 65-75% and the game is good to play again. Gpu usage back in high 90s.

    Haven't tried the latest driver yet. Might just stay on the hotfix one since things are working.

    Will try this later and let you know how it goes.
    Thanks for the advice. Much appreciated.

    Out of interest what gpu & cpu do you have?

    I've i5 8400
    1070ti
    16gb ddr4

    Specs - i7 3770K @ 4.4
    1070 G1 @2.1
    1080p @144hz
    16gb RAM (dual channel)
    Win 10 pro latest build.
    Still on hotfix driver.
    Mixed video settings to keep fps high.
    Cpu usage generally in the 65-75% range. Does go as high as 90% at times but the stutter and constant high cpu usage is solved since performing the above.
  • Tuco_Ramirez_1
    219 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, BF1IncursionsAlpha, Battlefield V Member
    Did you fix yours freakslade? You mentioned in the other thread about using fiercebrosnans settings. What were they and did they work?

    Sorry guys busy with work and I didn't get to respond to the other thread. There appears to be something up with the games settings after a patch and installing a new driver. I too had unusually high cpu usage same as others but manage to cure it totally by first downloading the hotfix driver. After doing so I reset the video settings in game to default. Set to dx 12 and FFR off. Restarted the game. Then chose my custom settings in video options and made sure V sync was off, motion blur 1%, framerate limiter - monitor refreshrate and gpu memory restriction OFF.

    The thing which I think made the most impact was hitting reset on the video settings after the hotfix driver installed. No more 90%+ cpu. Back to 65-75% and the game is good to play again. Gpu usage back in high 90s.

    Haven't tried the latest driver yet. Might just stay on the hotfix one since things are working.

    Will try this later and let you know how it goes.
    Thanks for the advice. Much appreciated.

    Out of interest what gpu & cpu do you have?

    I've i5 8400
    1070ti
    16gb ddr4

    Specs - i7 3770K @ 4.4
    1070 G1 @2.1
    1080p @144hz
    16gb RAM (dual channel)
    Win 10 pro latest build.
    Still on hotfix driver.
    Mixed video settings to keep fps high.
    Cpu usage generally in the 65-75% range. Does go as high as 90% at times but the stutter and constant high cpu usage is solved since performing the above.
    Just tried it there. I'm still having problems with fps drops and high cpu usage. I will try messing around with drivers again. Currently on the latest ones that came out yesterday or today.
  • FierceBrosnan007
    1016 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha, Battlefield V Member
    FierceBrosnan007 said:


    Tuco_Ramirez_1 wrote: »


    FierceBrosnan007 wrote: »


    Tuco_Ramirez_1 wrote: »
    Did you fix yours freakslade? You mentioned in the other thread about using fiercebrosnans settings. What were they and did they work?



    Sorry guys busy with work and I didn't get to respond to the other thread. There appears to be something up with the games settings after a patch and installing a new driver. I too had unusually high cpu usage same as others but manage to cure it totally by first downloading the hotfix driver. After doing so I reset the video settings in game to default. Set to dx 12 and FFR off. Restarted the game. Then chose my custom settings in video options and made sure V sync was off, motion blur 1%, framerate limiter - monitor refreshrate and gpu memory restriction OFF.



    The thing which I think made the most impact was hitting reset on the video settings after the hotfix driver installed. No more 90%+ cpu. Back to 65-75% and the game is good to play again. Gpu usage back in high 90s.



    Haven't tried the latest driver yet. Might just stay on the hotfix one since things are working.



    Will try this later and let you know how it goes.

    Thanks for the advice. Much appreciated.



    Out of interest what gpu & cpu do you have?



    I've i5 8400

    1070ti

    16gb ddr4



    Specs - i7 3770K @ 4.4

    1070 G1 @2.1

    1080p @144hz

    16gb RAM (dual channel)

    Win 10 pro latest build.

    Still on hotfix driver.

    Mixed video settings to keep fps high.

    Cpu usage generally in the 65-75% range. Does go as high as 90% at times but the stutter and constant high cpu usage is solved since performing the above.

    Just tried it there. I'm still having problems with fps drops and high cpu usage. I will try messing around with drivers again. Currently on the latest ones that came out yesterday or today.

    Haven't got to try that driver yet. Up to eyeballs with work. Will test next week. Was tearing hair out with the high cpu usage and low gpu usage too until it just all clicked and was back to normal performance. Keep toying around with the video settings in game. Something there is causing the weird performance. Things seem to reset themselves every time you adjust a preset so make sure to check all again.

    Hopefully you find what's up.
  • MURLAV
    53 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, Battlefield V Member
    Guys i found very weird thing:))With last NVdriver also installed Geforce Expirience.I went there,in BF5 adjusted optimized settings(whatever u want,more quality or performance)than pushed OPTIMIZED.Game started as normal without stutters.
  • Tuco_Ramirez_1
    219 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, BF1IncursionsAlpha, Battlefield V Member
    What did you set the slider to? Can you remember. I tried it there and left it on the green middle setting but it's still really bad. Spending hours of my time trying to fix this broken game. It's becoming a joke.
  • MURLAV
    53 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, Battlefield V Member
    edited May 10
    What did you set the slider to? Can you remember. I tried it there and left it on the green middle setting but it's still really bad. Spending hours of my time trying to fix this broken game. It's becoming a joke.
    moved slider to the left(PERFORMANCE),untill  all settings on HIGH,check settings list while moving slider,it helps for me
  • Tuco_Ramirez_1
    219 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, BF1IncursionsAlpha, Battlefield V Member
    OK thanks, will try that also.
  • Tuco_Ramirez_1
    219 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, BF1IncursionsAlpha, Battlefield V Member
    Still the same for me unfortunately..
  • HydroExcursion
    209 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, Battlefield V Member
    reason why i wont download that driver.
    period
  • Tuco_Ramirez_1
    219 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, BF1IncursionsAlpha, Battlefield V Member
    reason why i wont download that driver.
    period

    Which driver are you on?
  • KuroNeko_PRT
    247 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, Battlefield V Member
    People need to learn that you don't update driver if the actual one is working fine. Update only if you want it to support newer games.
  • Tuco_Ramirez_1
    219 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, BF1IncursionsAlpha, Battlefield V Member
    People need to learn that you don't update driver if the actual one is working fine. Update only if you want it to support newer games.

    OK smarty, what about the people upgrading hardware or the people doing fresh installs of Windows after purchasing new hard drives etc etc....
  • SteveZee
    359 postsMember, Battlefield 4, Battlefield, Battlefield 1, Battlefield V Member
    Still the same for me unfortunately..
    Have you tried resetting the game settings to default? Then switching back?

    Clean booting your system?

    Clean install of your graphics driver?
  • Sk1lld
    556 postsMember, Battlefield 3, Battlefield 4, Battlefield, Battlefield 1, Battlefield V Member
    edited May 11
    If you are running Win 10 Ver# 1809 and a 1070/1080 card some are reporting the 425.31 to be best.
    .
    If you are running a RTX 20xx card on Win 10 Ver# 1903 then the 430.64  works all right.
    .
    If you are running SLI the 425.31 are reported to work correctly.
    .
    As with all downgrades/upgraded drivers I use DDU, you can find it on the gforce driver forum stickied at the top.
    GL
  • Billy_bSLAYER
    10 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, CTE, BF1IncursionsAlpha, Battlefield V Member
    Ever since issues after 417.71 I DDU back to 417.71 and have been there ever since with no issues at all. 1080ti on a Z390 board.
  • Tuco_Ramirez_1
    219 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, BF1IncursionsAlpha, Battlefield V Member
    SteveZee wrote: »
    Tuco_Ramirez_1 said:
    Still the same for me unfortunately..

    Have you tried resetting the game settings to default? Then switching back?

    Clean booting your system?

    Clean install of your graphics driver?

    Hi mate, yes tried all that. Currently on a fresh Windows install and just trying the driver suggested below (425.31).
  • KuroNeko_PRT
    247 postsMember, Battlefield 3, Battlefield 4, Battlefield Hardline, Battlefield, Battlefield 1, Battlefield V Member
    People need to learn that you don't update driver if the actual one is working fine. Update only if you want it to support newer games.

    OK smarty, what about the people upgrading hardware or the people doing fresh installs of Windows after purchasing new hard drives etc etc....
    Download before hands the driver that was working fine. You can download old drivers in NVIDIA's website.
Sign In or Register to comment.