¡Tenemos novedades sobre el foro que compartir con vosotros! Echadles un vistazo aquí.

Posible solución a la caída de FPS

«13
X-Bonio-X
108 postsMember Publicaciones: 116 Member
Hola gente, anoche mientras probaba ya frustrado la configuraciones de BF1, se me diò otra vez por borrar la carpeta settings y al entrar a una partida lo que hice fue poner en la opción de pantalla ''Sin Bordes'' para mi sorpresa los tirones y las caídas de fps se habían ido casi del todo, tenia entre 65 a 80 fps en el mapa de Herida de San Quintin, en Albion no tenia caída de fps prácticamente, no apareció nunca el mensaje de caída de fps.
Salí del juego, jugué en Monte Grappa y comenzó otra vez para mi sorpresa, cuando miras el paisaje suelen haber bajones, a diferencia de ''Pantalla Completa'' que es re injugable y te tira terrible tirones, en ''Sin Bordes'' hay caídas pero es bastante jugable este mapa, un 70% jugable, al momento de arrancar en Amiens ya la cosa volvió a dar asco, antes de eso había configurado y puesto todo en Ultra, pero ojo, cuando borro la carpeta settings y queda en ''Auto'' igual queda todo en Ultra, es un bug de las opciones de vídeos me parece, volviendo al tema, en Amiens ya daba asco y tuve que salir del juego. Ésta mañana volví a borrar la carpeta, volví a poner la opción de Sin Bordes, Dx 12 activado, arranqué en Achi Baha (creo que así se escribe) y todo andaba normal, durante las batallas donde explota todo y hay mucho movimiento suelen haber caídas, de 65-70 paso a 50 y a veces 45, pero vuelvo a aclarar, con esta configuración es re jugable todavía, èste mapa es 80% jugable.
En el mapa Galitzia me paso algo similar, por momento anda todo mas que bien y después hay bajones pero sigue siendo jugable.

Lo que si no entiendo, cual es la diferencia entre Pantalla Completa y Sin Bordes? anoche me quería arrancar los pelos que no entendía como ***** funcionaba bien así, a nivel gráfico no noto nada, o estaré mal no sè.

Configuración de BF1

Pantalla: Sin Bordes

Sincronizacion Vertical desactivada (la activè y no noto tanta diferencia como antes, se mantiene 60, pero en batallas no tanto, si la desactivo creo que es mas fluido en las batallas)
Alto Rango Dinámico: Auto

Modo de alto rango dinámico: HDR10

Restricción de GPU: Si

Dx 12: Activado

Calidad Grafica: AUTO (Vuelvo a aclarar que por defecto quedò todo en ULTRA).

Resolución: 1920x1200p (Quedò así por defecto)

Aclaro que juego desde navidad del 2016, y no conocía la caída de fps, iba todo en ultra 1080p con DX 12, no sè que les cuesta hacer ingeniería inversa, son una empresa grande, no tienen un equipito chico, déjense de joder.

Mi pc:
Procesador: i5 6400
Gráfica: RX 470 4GB
RAM: 16GB 2133Mhz DDR4
Disco: Disco de 1 TB (no es solido, aclaro por las dudas :v)

Comentarios

  • DRAGONCOJO
    72 postsMember Publicaciones: 76 Member
    Bueno luego pruebo, aunque no sé cómo me irá directx12 ayer lo puse y no iba muy bien tengo una gt1030 en Nvidia va peor dicen. De todas formas según que servidor pones parece que va mejor o peor
  • tiger800xcx
    116 postsMember Publicaciones: 133 Member
    Yo he llegado a la conclusion de q lo mejor es borrarlo, la grafica y micro sufriran menos y nos llevaremos menos sofocones con semejante mierda de juego mal optimizado, otra opcion es tambien comprarse un pc de 4000 euros como un amigo mio q dice q le va genial , te quieres ir al caraj.... DICE
  • X-Bonio-X
    108 postsMember Publicaciones: 116 Member
    Actualización

    Hace un rato me eche unas partidas, hice lo mismo, pero ésta vez quedò Dx 12 desactivado y sinc vert. activada, tenia bajones y eran bastante notorios y en algunos casos molestos, desactivo la opción y el cambio es mas que sustancial, tengo entre 60-80 fps, la verdad que no entiendo, este juego anda cuando quiere y otra cosa que no puedo explicar es porque tengo entre 65-80 fps en Bosque Argonne y en Soissons tengo caídas de hasta 45 fps que ya son molestas, NO ENTIENDO, en un mapa que esta lleno de vegetación y sombras, por ende debería ser al revés.

    No se si tiene que ver, pero ayer o antes de ayer se actualizo el S.O, tengo Windows 10 y al ejecutar dxdiag me sale Sistema Operativo: Windows NT(6.2, versión de compilación 9200)

    Es que ningún moderador lee, cuando se van a dignar en arreglar esto o dejar algún mensaje al respecto?.
  • X-Bonio-X
    108 postsMember Publicaciones: 116 Member
    Actualización

    Hoy de nuevo me eche unas partidas y notè otra cosa, en mapas como Verdum, solía tener terribles caídas de fps, en Soissons sigue todo igual me parece y ni hablar Amiens, pero por ejemplo hoy en Verdum en ningún MOMENTO experimentè caida de fps y eso que tratè de buscarlo metiéndome en el medio de las batallas y frentes de batalla, pero nada, así que mi pregunta ahora es: Tiene que ver con algo el servidor?. porque en otro servidor tenia terribles caídas y tenia la misma configuración gráfica.
  • fabianmg42
    10 postsMember Publicaciones: 10 Member
    Este juego va bien por días y por horas no tengo ni la menor idea del por que aunque tengo una teoría la cual tiene que ver con los servidores y el uso alto de cpu ,antes tenia un i5 4460 con una gtx 1060 y bf1 era injugable ,se podía hacer algo activando vsync y fast sync pero hasta ahí,acabo de actualizar mi hadware compre 16 gb de ram 2x8 a 2666mhz un i5 8400 con la misma gráfica y el juego revienta mi procesador en mapas como amiens y san quentin,es increíble que un procesador con 6 núcleos este siempre al 100% en este juego,lo que yo eh echo es crear un archivo cfg,poner en alta prioridad el juego(esta opción logro que desapareciera el microstutering que solía tener al jugar) desactive el origin en el juego,esto fue lo que mas me ayudo a mi,no quiero ni imaginar las personas que tengan un hadware menos potente debe ser una pesadilla correr bf1 esperemos y después se decidan por fin a optimizar el uso de la cpu ya que es bastante molesto tener que uno mismo hacer magia para optimizar un juego que ya tiene 1 año en el mercado.
  • X-Bonio-X
    108 postsMember Publicaciones: 116 Member
    fabianmg42 escribió : »
    Este juego va bien por días y por horas no tengo ni la menor idea del por que aunque tengo una teoría la cual tiene que ver con los servidores y el uso alto de cpu ,antes tenia un i5 4460 con una gtx 1060 y bf1 era injugable ,se podía hacer algo activando vsync y fast sync pero hasta ahí,acabo de actualizar mi hadware compre 16 gb de ram 2x8 a 2666mhz un i5 8400 con la misma gráfica y el juego revienta mi procesador en mapas como amiens y san quentin,es increíble que un procesador con 6 núcleos este siempre al 100% en este juego,lo que yo eh echo es crear un archivo cfg,poner en alta prioridad el juego(esta opción logro que desapareciera el microstutering que solía tener al jugar) desactive el origin en el juego,esto fue lo que mas me ayudo a mi,no quiero ni imaginar las personas que tengan un hadware menos potente debe ser una pesadilla correr bf1 esperemos y después se decidan por fin a optimizar el uso de la cpu ya que es bastante molesto tener que uno mismo hacer magia para optimizar un juego que ya tiene 1 año en el mercado.

    Disculpame, como puedo crear ese archivo cfg o donde puedo ver como hacerlo?.

    De antemano gracias!
  • DRAGONCOJO
    72 postsMember Publicaciones: 76 Member
    -En el ADMINISTRADOR DE TAREAS, Detalles, el ejecutable del Battlefield 1, en PRIORIDAD ALTA. Para hacer esto, hay que hacerlo con el juego funcionando. Esto lo he leído x los foros, bueno haber cómo se hace con cfg, y lo pruebo también.
  • Huasonic0
    19 postsMember Publicaciones: 20 Member
    Ayer le di prioridad alta y la verdad que sentí una leve mejora.
  • Belfast91
    2 postsMember Publicaciones: 2 Member
    editado 9. ene 2018, 20:59
    Buenas,

    Contando con que tengo una GTX 1080ti tenia unas horribles bajadas de Frames en los mapas clasicos (Los de las expansiones me funcionaban mejor)

    En mi caso y tras probar mil y una historias (modificar el fichero cfg, diversos Drivers de Nvidia, varias versiones de Windows...). Cuando jugaba miraba todo el rato el monitor de procesos y siempre veia la CPU rozando el 100% y cuando de vez en cuando tocaba el 100% comenzaban los bajones, por lo que el problema era mi CPU. Me decidi a cambiar de procesador y jubilar mi i5 4670 (comprado en 2013). Me he decantado por un I5 8600K de 6 nucleos y la mejora es espectacular... es decir en todos los mapas no he tenido ningun bajon de FPS, se mantiene a 120 como una roca en operaciones.

    Por desgracia este juego tiene una CPU dependencia exagerada, no se si debido a una mala optimizacion o a que, la cuestion es que la solución en mi caso fue dejar ya los 4 nucleos para pasarme a los 6 y voila... adios bajadas

    Un saludo
  • DRAGONCOJO
    72 postsMember Publicaciones: 76 Member
    Yo probé prioridad alta, y bueno no sé algo, parece quizás, lo de la CPU al 100% me pasa en según qué servidor, si entró en uno que ya no se ha puesto y la GPU va a 98 a 100 ya mapa tras mapa , va tirandome bien , tengo un g4560 Nvidia gt1030 y 8 GB RAM , juego con un equipo de pena pero cuando va bien juego decentemente .creo para mí opinión que los servidores tienen algo que ver o en gran parte
  • fabianmg42
    10 postsMember Publicaciones: 10 Member
    Tienes que crear un block de notas dentro del directorio del juego,ponerlo de nombre user.cfg,en la casilla de abajo despliegas las opciones y pones todos los archivos en el block de notas tienes que pegar estos comandos :

    RenderDevice.RenderAheadLimit 2

    GameTime.MaxVariableFps 65

    Thread.ProcessorCount 6

    Thread.MaxProcessorCount 6

    en tu caso en thread pones el numero de núcleos eh hilos que tiene tu procesador en mi caso son 6 lo demás lo dejas igual en el caso de game time si lo dejas en 61 o 60 es posible que tengas screan tearing por lo que lo recomendable es dejarlo en 65 esto disminuye un poco el alto uso de cpu
  • DRAGONCOJO
    72 postsMember Publicaciones: 76 Member
    En foros vi esto
    Tambien probaria alguna cfg para que te limite efectos del juego y ganes algun fps mas. Existe un comando con el cual puedes balancear el uso de la cpu y gpu (RenderDevice.RenderAheadLimit). Los valores de este comando son el 0,1,2 y 3 (hay que ir probandolos a ver cual te da mejor resultado). Lo que hace es limitar en nº de fps que envia a procesar la cpu a la gpu, que aunque te bajen algo los fps estos son mucho mas estables y seguramente tendras menos bajones.
    Del renderdevice al 2 cuanto le da el 0 el 1 2,y 3 de porcentaje cpu-gpu? Ponemos 2 y si no vamos probando resto ?
  • fabianmg42
    10 postsMember Publicaciones: 10 Member
    Pues por experiencia propia el 2 es el que mejor funciona pero hay algo que tienes que tener claro el user.cfg no hace milagros yo lo tenia en mi antiguo i5 4460 y pues hubo un punto en que ya ni siquiera funcionaba ese comando,lo que hay que tener claro es que si no cumples los mínimos requisitos en el caso de intel pues ni a ganchos corre el juego es mas en gente con hadware mas potente suelen tener problemas,igual no se rompan mas la cabeza este juego tiene un problema serio con el uso de cpu,nosotros como usuarios y consumidores no podemos hacer mucho para arreglarlo hay que esperar que dice lo optimice aunque al paso que va el próximo bf2 ya estará en el mercado,nos falta ya solo un dlc y la verdad no creo que hagan nada por arreglar el problema del cpu.
  • DRAGONCOJO
    72 postsMember Publicaciones: 76 Member
    No si el problema , es que gente con los mínimos requisitos y recomendados , les va mal . Bueno ya lo iré probando x ahora no he notado mucho, como dices no hace milagros,pero bueno, voy probando haber todo lo que voy viendo en los foros y demas
  • X-Bonio-X
    108 postsMember Publicaciones: 116 Member
    fabianmg42 escribió : »
    Tienes que crear un block de notas dentro del directorio del juego,ponerlo de nombre user.cfg,en la casilla de abajo despliegas las opciones y pones todos los archivos en el block de notas tienes que pegar estos comandos :

    RenderDevice.RenderAheadLimit 2

    GameTime.MaxVariableFps 65

    Thread.ProcessorCount 6

    Thread.MaxProcessorCount 6

    en tu caso en thread pones el numero de núcleos eh hilos que tiene tu procesador en mi caso son 6 lo demás lo dejas igual en el caso de game time si lo dejas en 61 o 60 es posible que tengas screan tearing por lo que lo recomendable es dejarlo en 65 esto disminuye un poco el alto uso de cpu

    Dentro de la carpeta de Battlefield 1 que està en documentos y lo pegas dentro de la carpeta Settings???
  • X-Bonio-X
    108 postsMember Publicaciones: 116 Member
    fabianmg42 escribió : »
    Tienes que crear un block de notas dentro del directorio del juego,ponerlo de nombre user.cfg,en la casilla de abajo despliegas las opciones y pones todos los archivos en el block de notas tienes que pegar estos comandos :

    RenderDevice.RenderAheadLimit 2

    GameTime.MaxVariableFps 65

    Thread.ProcessorCount 6

    Thread.MaxProcessorCount 6

    en tu caso en thread pones el numero de núcleos eh hilos que tiene tu procesador en mi caso son 6 lo demás lo dejas igual en el caso de game time si lo dejas en 61 o 60 es posible que tengas screan tearing por lo que lo recomendable es dejarlo en 65 esto disminuye un poco el alto uso de cpu

    Ya lo apliqué correctamente, cambie el archivo a CFG y use otra configuración que es la siguiente:

    PerfOverlay.DrawFps 1
    PostProcess.BlurMethod 0
    PostProcess.DofMethod 0
    PostProcess.DynamicAOEnable 0
    PostProcess.DynamicAOMethod 0
    Render.DrawScreenInfo 0
    Render.VSyncFlashTestEnable 0
    RenderDevice.Dx11Dot1Enable 0
    RenderDevice.Dx11Dot1RuntimeEnable 0
    RenderDevice.RenderAheadLimit 0
    RenderDevice.StereoConvergenceScale 0
    RenderDevice.StereoSeparationScale 0
    RenderDevice.StereoSoldierZoomConvergenceScale 0
    RenderDevice.TripleBufferingEnable 0
    RenderDevice.VSyncEnable 0
    UI.DrawEnable 1
    WorldRender.MotionBlurEnable 0
    WorldRender.MotionBlurMaxSampleCount 0
    WorldRender.MotionBlurQuality 0
    WorldRender.PlanarReflectionEnable 0
    WorldRender.SpotLightShadowmapEnable 0
    WorldRender.SpotLightShadowmapResolution 1
    WorldRender.TransparencyShadowmapsEnable 0
    GstRender.Thread.MaxProcessorCount 4
    Gametime.MaxVariableFPS 65

    El juego me va mejor y rara vez tengo caída de fps, solo cuando muero y me muestra el mapa es ahi donde por 2 o 3 segundos se me bajan los fps a 45, después se vuelven solos a 65. Estos consejos los saque de éste vídeo



    PD: mas adelante voy a cambiar los fps y en ves de 65 no voy a poner nada solo para ver que pasa porque si no están entre 80-65 fps mas o menos pero con mas caídas, antes de aplicar esta configuración minimizaba el juego y lo ponía en prioridad alta, gracias a eso tenia esos fps y ahora con esta configuración creo que todo va mas que bien.
  • DRAGONCOJO
    72 postsMember Publicaciones: 76 Member
    Yo lo probé y no me funciono :(
  • X-Bonio-X
    108 postsMember Publicaciones: 116 Member
    DRAGONCOJO escribió : »
    Yo lo probé y no me funciono :(

    Leí mas arriba las especificaciones de tu equipo, lamentablemente vas a tener que upgradear si o si. Si lo haces, postealo en este foro.
  • DRAGONCOJO
    72 postsMember Publicaciones: 76 Member
    Si, pero hasta que no ahorre , porque para un i5 de 7 generación de 4 núcleos, supongo que me irá igual y tendría que ir x un i7. Tengo para un tiempo aún, mientras a jugar como se pueda
  • X-Bonio-X
    108 postsMember Publicaciones: 116 Member
    DRAGONCOJO escribió : »
    Si, pero hasta que no ahorre , porque para un i5 de 7 generación de 4 núcleos, supongo que me irá igual y tendría que ir x un i7. Tengo para un tiempo aún, mientras a jugar como se pueda

    Anda por un Ryzen 5 1600x creo que es, fíjate es el Ryzen 5 mas groso, tiene 6 núcleos y para BF1 leí que va de putamadre, en Argentina el mas caro està 5 lucas, una ganga comparando precio-calidad. Intel es muy caro y últimamente se las están mandando con las actualizaciones.

Accede o Regístrate para comentar.

¡Bienvenido/a!

Pareces nuevo por aquí. Si quieres participar, ¡pulsa uno de estos botones!

Si tienes algún problema para acceder al foro, prueba a desconectarte totalmente, limpia la memoria caché, cookies y archivos temporales. ¡Reinicia tu navegador y ven a compartir con la comunidad oficial de Battlefield!