Battlefield 3 : "Impossible de lancer le jeu. Veuillez vous assurer qu'il est correctement installé"

Whyllo
2 postsMember, Battlefield, Battlefield 3, Battlefield 4, Battlefield 1, BF1 Incursions Alpha Messages: 3 Member
Bonjour,

Comme indiqué dans le titre, il m'est impossible de "jouer" à Battlefield 3, après plusieurs désinstallation et réinstallation de celui-ci, ainsi que d'Origin.


Avant d'expliquer les faits, voici ce que j'ai comme matériel:

- Acer Predator G5910
- Windows 7 Edition Familiale Premium
- Intel (R) Core (TM) i7-2600 CPU @ 3.40 GHz (64 Bits) DirectX 11
- 12Go de RAM PC3-10700 (DDR3) (Non d'origine)
- AMD Radeon R7 200 Series (Non d'origine)
- Type de port de la CG : PCI
- Alimentation Package 40.79 W (Max)
- IA Cores 36.36 W (Max)
- Nombre de cœurs de processeur 4
- Résolution du moniteur principal 1920x1080
- Mémoire graphique totale disponible 4854 Mo
- Mémoire graphique dédiée 2048 Mo
- Mémoire système dédiée 0 Mo
- Mémoire système partagée 2806 Mo

(N'hésitez pas à me dire, si qqch est manquant)



Après maintes recherches sur divers forums/sites, les solutions proposées ne m'ont malheureusement pas aidé à résoudre mon souci..

Pour commencer et faire dans l'ordre,

- Origin est installé au chemin suivant: (C:)>>>Program Files (x86)>>> Origin
- Battlefield 3 (Avec tous les DLC) est installé au chemin suivant: (C:)>>>Program Files (x86)>>>Origin Games>>> Battlefield 3

Ils sont tous les deux exécutés en "Administrateur"
Pour Origin dans "Paramètre d’application" >>> "Option de démarrage", "Service Origin Helper" est bien activé.
Pour Battlelog que j'utilise sous FireFox, dans les paramètres du profil j'ai coché la case " Lancez le jeu sans avoir besoin de plugin". (Lorsque je décoche la case et que je tente de rejoindre une partie, j'ai un message qui me dit que je dois mettre les plugin à jour. Chose que je fais, mais le message persiste même après avoir installé le dernier plugin...)
PunkBuster est bien à jour.


Ensuite, lorsque je tente de rejoindre un serveur vide, parfois j'ai le message d'erreur suivant qui apparaît "Impossible de lancer le jeu. Veuillez vous assurer qu'il est correctement installé".
Sur d'autres serveurs vide, le souci n'apparaît pas.
Par contre, dès que je souhaite rejoindre un serveur avec plusieurs joueurs, là, avec toujours le même message, je ne peux pas rejoindre la partie...


Un ami, qui a réinstallé le jeu en même temps que moi, qui a les mêmes options sous Origin/Battlefield 3 installé au même endroit/Battlelog à jour. Pour lui, tout fonctionne parfaitement. Je ne comprends donc pas d'où le souci peut-il venir...


Est-ce qu quelqu'un a déjà eu ce genre de soucis par le passé ? Comment le résoudre?


Grand merci pour vos réponses.

Réponses

  • Ectar
    763 postsMember, Battlefield, Battlefield 3, Battlefield 4, Battlefield 1, BF1 Incursions Alpha, Battlefield V Messages: 779 Member
    3 mars modifié
    Bonjour,

    Pour commencer :

    - Tente une réparation du jeu ; clic droit sur la jaquette de Battlefield 3 dans ta bibliothèque de jeux puis sélectionne réparer

    Autre solution :

    - Ferme Origin
    - Rend toi ici c:/windows/system32 et efface le fichier d3dcompiler43.dll 
    - Ensuite, exécute DXSETUP.exe, le chemin par défaut est C:\Program Files (x86)\Origin Games\Battlefield 3\ __Installer\directx\redist
    - Essaie de relancer le jeu

    ▬▬▬▬•٠●๑۩۞۩❤ DxDiag Fan ❤۩۞۩๑●•٠▬▬▬▬
  • Whyllo
    2 postsMember, Battlefield, Battlefield 3, Battlefield 4, Battlefield 1, BF1 Incursions Alpha Messages: 3 Member
    Bonjour,

    Merci pour ton retour.

    J'avais oublié de préciser dans mon post initiale que, j'avais déjà effectué des réparations du jeux...
    Je l'ai quand-même fait en suivant ton conseil, même résultat..
    Merci tout de même !


    J'ai également essayé avec ton autre solution, mais malheureusement le souci est toujours là.

    Je n'arrive pas à comprendre ce qui est bloquant...
    Est-ce que des screens de mon dossier Battlefield 3 pourraient être utile? Ou autre chose ?
  • Ectar
    763 postsMember, Battlefield, Battlefield 3, Battlefield 4, Battlefield 1, BF1 Incursions Alpha, Battlefield V Messages: 779 Member
    3 mars modifié
    Pourrais-tu tenter de passer par Internet Explorer; télécharger le plugin puis tenter de lancer le jeu ?

    ▬▬▬▬•٠●๑۩۞۩❤ DxDiag Fan ❤۩۞۩๑●•٠▬▬▬▬
  • MisterGarzok
    3579 postsMember, Moderator, Battlefield, Battlefield 3, Battlefield 4, Battlefield 1, BF1 Incursions Alpha, Battlefield V Messages: 3,600 Moderator
    Bonjour,
    @Whyllo, regardez les manipulations ici pour le Plugin :
    http://battlelog.battlefield.com/bf4/fr/forum/threadview/2955064797299768212/1/
    https://forums.battlefield.com/fr-fr/discussion/5607/firefox-52-et-plug-in-battlelog-la-solution
    https://imgur.com/7nD8E1B
    Ou tentez de lancer le jeu avec un autre navigateur comme conseillé au-dessus.
    MisterGarzok EA Modérateur Battlefield FR \/ DICE Friend BF1 BFV \/ Héro AHQ \/ Assistance Technique
  • Whyllo
    2 postsMember, Battlefield, Battlefield 3, Battlefield 4, Battlefield 1, BF1 Incursions Alpha Messages: 3 Member
    Bonjour,

    Merci à tous les deux pour vos retour.

    @Ectar , j'ai tenté avec Internet Explorer (Version 11), je télécharge de nouveau le plugin, mais là même tarif... La fenêtre d'installation du plugin s'ouvre, tout se passe bien, je clique sur "Après avoir installé le plug-in de navigateur, cliquez sur continuer", mais la fenêtre pour télécharger et installer le plugin revient continuellement après avoir cliqué.. Après vérification sur Revo, le plugin est bien installé. Toujours sous IE 11, j'ai tout de même coché dans les paramètres du profil la case " Lancez le jeu sans avoir besoin de plugin", le message d'erreur comme quoi le jeux est mal installé revient toujours.

    @MisterGarzok J'ai proprement désinstallé Mozilla Firefox avec Revo, j'ai suivi à la lettre le tuto proposé par @Sgt_FR_Bidochon, mais dès le départ après installation de Mozilla Firefox 51 (Version 43Mo), et avant l'installation de la version 52 ESR je mets about:config dans le navigateur et la ligne "plugin.load_flash_only True" est juste inexistante...
    Puis dans C:\Program Files (x86)\Mozilla Firefox, le fichier "Update channel-prefs.js" est manquant. Pour le fichier update-settings.ini, j'ai pu apporter la modification sans soucis.

    Si vous avez d'autres solutions à me proposer, je suis preneur.
    Si je peux fournir des éléments concernant le dossier d'installation du jeux, ou tous autres éléments pouvant être utiles, n'hésitez pas à me le faire savoir.
Connectez-vous ou Inscrivez-vous pour répondre.

Salutations, Étranger !

Si vous souhaitez rejoindre la communauté, cliquez sur l'un de ces boutons.